Users may experience a 503 error message when accessing canva.com.

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Mar 12, 2026 - 11:06 AEDT

Investigating

We are currently investigating this issue.
Posted Mar 12, 2026 - 10:28 AEDT