Media uploads failing for some users

Incident Report for Canva

Resolved

This incident is now mitigated. Thank you for your patience and understanding.
Posted Mar 12, 2026 - 15:53 AEDT

Update

Media uploads may be failing for some users.
Users may experience the following error message:
"We were unable to upload {{file}}. You might be logged out, offline or Canva's servers are unreachable."
We are currently investigating and working to mitigate the issue.
Posted Mar 12, 2026 - 15:34 AEDT

Investigating

Media uploads may be failing for some users.
Users may experience the following error message:
"We were unable to upload {{file}}. You might me logged out, offline or Canva's servers are unreachable.
Posted Mar 12, 2026 - 15:33 AEDT
This incident affected: Media uploads.